My thoughts on BullGuard

Posted 3/11/2014 8:28 PM
#96738
User avatar

Anonymous21 Member

Date Joined Nov 2016
Total Posts: 2
My free trial, which I received along with my computer from PC Specialist, is about to run out and I just wanted to say what my experience was like using BullGuard. It annoyed me since day one of using it. One of the first things that annoyed me since day one was the little pop up in the bottom right of my screen asking me if I want to allow a program the access to the internet, especially when the pop up appeared in the background and I didn't know why any of my programs that used internet didn't work because I didn't see the pop up. Other issues were not so common but just as annoying if not more. I remember I tried to install something and it kept getting stuck when I tried to turn it on (I can't remember exactly what the program was since it was some time ago). I figured out that the problem was with the firewall not allowing it access. I checked the Windows firewall which said the program had full access and there was no problems, so I checked the firewall on BullGuard, which didn't even show the program listed, I don't remember how but in the end I got it working but I was annoyed that I had to waste time because my antivirus was blocking the program and not informing me about it. The next issue I found is when there's a YouTube video on any forum or website other than YouTube. When I tried to watch the video an error would pop up saying "An error has occurred". This happened to any video I tried to watch, I then tried to watch the same video on the YouTube thinking the problem was with the forum but the same error came up, but not on other videos. The antivirus gave me problems before like I mentioned so that was the first thing I checked. I turned it off and the video worked without any problems. To make sure it was the antivirus not a problem with YouTube servers I turned BullGuard on again and tried to watch the video again, it didn't work. The final problem that I remember happened just today and it was to do with YouTube again. In the last problem I mentioned videos on forums not working and giving me an error, well today this is happening on every video on YouTube. I remembered that the last time I got that error was because of BullGuard so that's the first place I went to try to fix the error, and guess was, turning BullGuard off made all the videos work again! Of course turning it back on broke them again. I tried restarting my computer which didn't solve it. This annoyed me so much that I decided to write this. Now don't get me wrong, I didn't write this to complain and make the creators feel bad, because in my opinion writing negative stuff about something just to annoy the creators because I didn't like they way the did something is a waste of time. I did however write this to hopefully make the creators address these issues because I'm sure I'm not the only one getting annoyed by these.
Posted 3/19/2014 4:27 AM
#96766
User avatar

Advanced member

Please rest assured that your feedback is valuable to us! I will make sure it reaches the appropriate management.

I only regret that you did not try the free support service we offer with BullGuard. Most of the annoyances and issues could have been easily solved.

Thank you!
Andreea-Luciana Ostache
Support Team Leader
[url]support@bullguard.com[/url]
www.bullguard.com

Download the Free Trial version of BullGuard Internet Security 16

You have a BullGuard related problem? Post your question on these forums, contact Support or contact me on Twitter!
Posted 3/19/2014 5:17 PM
#96774
User avatar

Anonymous21 Member

Date Joined Nov 2016
Total Posts: 2
Well i didn't use it because I solved most of the issues myself such as the firewall thing, and the other issues such as the errors on YouTube just fixed themselves.
  • Unread posts or replies
  • No unread posts or replies
  • Unread Posts (Read Only Forum)
  • No Unread Posts (Read Only Forum)

Forum Information

Currently it is Monday, December 5, 2016, 9:45 PM (GMT +1)
There are a total of 61,160 posts in 13,449 threads.
In the last 3 days there were 2 new threads and 3 reply posts.

Who's online

This forum has 37,965 registered members. Please welcome our newest member, Old shape.
There are currently no users on-line.