The original version of this page can be found at : http://forum.bullguard.com/forum/15/Mouse-Driver-loading-too-slow-_96844.html
Posted By : J Moore - 4/6/2014 10:59 PM
Hi,

I have a Dell 17R N7110 which is fitted with a touchpad made by ALPS. The touch pad works fine, except gesture control. It seems the base mouse functionality loads fine on start up, but the gesture functionality seems to be initiated only when the program apoint.exe has been started.

When using msconfig, I can see the startup program "Alps Pointing-device Driver" in the list, and its being started by registry location. When I turn on my laptop, I notice this driver being loaded slowly, after Bullguard and some other programs. Obviously Bullguard should run reasonalbly quickly at startup, but how can I either start the driver quicker than Bullguard, or get Bullguard to load it ?

I start my web browser quickly, but sometimes the scroll functionality hasn't started (because the driver hasn't loaded). This is annoying. Bullguard does take some time to start, and this problem isn't really a Bullguard problem.

I'm hoping there is a way to change the start priority. Ideally I want the mouse driver to run before Bullguard. There exists already some scheduler programs to delay starts, but that isn't really what I need to do. I just need to change the priority. I've not been able to find a solution just by googling around

Thanks

Posted By : Andreea-Luciana Ostache - 4/7/2014 8:14 PM
While I understand your issue, messing with the drivers is not a good idea. BullGuard has a few drivers/services that are imperative to load first, but the rest wait for your other drivers/services to load.

Try to put the BullGuard Update Service on Automatic (delayed start) in services.msc (you need to disable the option "Allow BullGuard to protect it's components" from Settings > Advanced > General > Main, to be able to change the servicem but re-enable it afterwards).

Let us know of the result.


Andreea-Luciana Ostache
Senior Support Technician EN
support@bullguard.com
www.bullguard.com

Download the Free Trial version of BullGuard Internet Security 14

You have a BullGuard related problem? Post your question on these forums, contact Support or contact me on Twitter!


Posted By : J Moore - 4/7/2014 11:36 PM
Thanks for the tip. I did this, and I noticed a slight improvement. It didn't solve my problem, but every little bit helps.
There are many services I could modify in a similar way, that I don't need at startup straight away, eg Bluetooth.

I think with a little fine tuning, I can at least get things to an aceptable speed to get the touchpad working faster.

The autologin is very quick. The laptop doesn't seem to have anytime to get "ready". I could go back to normal login, but I want
to use Truecypt soon, and then I have a boot password (so I don't want to have to type in two passwords).

Thanks.

Posted By : Andreea-Luciana Ostache - 4/10/2014 7:02 AM
You can try making an bat file for the "apoint.exe" to run when your computer starts (add to the Startup folder) or to run before starting the browser.

This guide will help you with what to do: www.eightforums.com/tutorials/40287-cpu-priority-shortcut-program-create-windows.html


Andreea-Luciana Ostache
Senior Support Technician EN
support@bullguard.com
www.bullguard.com

Download the Free Trial version of BullGuard Internet Security 14

You have a BullGuard related problem? Post your question on these forums, contact Support or contact me on Twitter!


Posted By : J Moore - 4/15/2014 12:15 AM
This suggestion isn't such a great idea for my problem, as this won't speed up loading of the driver. It would increase it's runtime priority, but I don't need to improve this.

But thanks anyway. I did experiment with changing other services which start automatically, and setting them to delayed. This has brought a positive effect.

Services like Bluetooth I don't need straight away. Also for example Adobe Acrobat update service doesn't need to start immediately.
-->