The original version of this page can be found at :
Posted By : J Moore - 4/12/2014 10:04 PM

I have an unusual problem. I'm using a friends wifi, and my laptop auto logs-in, and connects.
The internet connects fine, for about 20 secs, then I have no (internet) connection. No connection means that
I'm connected to the wifi access point always, but internet access is blocked. If I turn off the firewall, I then have access,
but if I turn it on again, I'm blocked after a few seconds.

But .. If I leave Bullguard firewall on (even though the internet is blocked), then disconnect the wifi, and then reconnect, all is well !
Internet access is then not blocked, and keeps working.

So what is going on ? Why do I have to disconnect the wifi connection, then re-connect again, for internet access to work ?
Any ideas how I can debug this problem ?
I'm only using Bullguard's firewall, and when internet access is blocked, and I take a look at Bullguard, it is sometimes not responding.

Posted By : wafu - 4/13/2014 4:26 PM
someone needs to look at this, as i'm experiencing the same symptoms, have even just returned a 3 wk old router as faulty only to find same fault on the new one, connection cycles between being connected and not....... also having bullguard not responding at times

belkin n300 wireless modem router, win 7, 4gb ram, quad core, intel r 82566 2gb network connection

Posted By : NorthPole - 4/13/2014 5:17 PM
I've found quite a few times in recent weeks that attempts to update BullGuard manually immediately after the PC starts up have failed, generating a report that connection could not be made with the update server. Also, when I start my browser it sometimes cannot initially load the home page, as if internet connectivity has been lost. I have been putting this down to the slow start-up of the BullGuard firewall, which can be seen by watching the BullGuard main screen after starting the PC. I've also had the Windows 'BullGuard not responding' message at times, together with a blacked-out BullGuard main screen. This behaviour seems to be consistent with the above two posts, and does suggest to me there is a firewall problem. Was the firewall engine changed recently? - I found all my firewall rules had disappeared after a recent update.

Posted By : Robert Mateescu - 4/15/2014 12:17 AM
Hi there,

The issue is caused by browser add-ons or other programs that force a proxy.
BullGuard detects it and the connection is blocked.

I recommend you to run a Malwarebytes scan (use the free version, without enabling the trial for the full one) and remove all detected PUPs.

Let me know if the problem persists afterwards.

Robert Mateescu
Senior Support Technician EN

Download the Free Trial version of BullGuard Internet Security 2014

You have a BullGuard related problem? Contact our Support team directly:!

Posted By : NorthPole - 4/15/2014 3:36 PM
I happened to do just that yesterday, and no issues were reported (same story with SuperAntiSpyware). I've been wondering whether the Trusteer Rapport software driver (which creates a VPN) might be a cause, although it's never seemed to interfere with BullGuard up to now.

Posted By : wafu - 4/15/2014 7:09 PM
ran a malwarebytes scan, came back clean, my on/off connection problems lasts the whole time i'm online, both with firefox & internet explorer, just a tad frustrating shakehead

Posted By : J Moore - 4/29/2014 10:08 PM
I'm back to my "home" network, and everything works fine. It can't be a virus/malware problem, or I would still have the same problem on my home network. It is something else.
I now have a new problem with the firewall ... I'll raise a new issue for this. Now my local network can't be accessed when Bullguard firewall is turned on.
I have a NAS drive, on my local network (gateway address is Bullguard has added a "trusted network" automatically, but in reality this network is not trusted !
Discover isn't working, I can't ping my drive. It is not reachable. I've now turned off Bullguard firewall, and I'm using windows firewall instead. Trusted network feature is broken.

Posted By : Andreea-Luciana Ostache - 4/30/2014 8:40 AM
Please allow me to start with this statement: BullGuard Firewall is built on the best engine on the market. It's good and it works.
Now, when something doesn't work because of the BullGuard Firewall, it often turns up to be because it's driver is either not installed properly (doesn't have full permissions) or something blocks it from accessing the network correctly.

There are rare cases in which the Firewall does not allow network devices properly, for which special rules need to be created, such as XBOX or PS3 devices, sound stations or smart TV's.

I am certain that it is not normal behavior for it to block an entire LAN connection. Why this does happen and what to do to fix the problem is usually computer specific (user specific). This is why we need logs, to see what's going on.
Please contact support by e-mail first (for the logs, so they are saved in our system) and then by Live Chat, for the solution.


Andreea-Luciana Ostache
Senior Support Technician EN

Download the Free Trial version of BullGuard Internet Security 14

You have a BullGuard related problem? Post your question on these forums, contact Support or contact me on Twitter!

Posted By : J Moore - 4/30/2014 2:29 PM
I noticed you posted on my other ticket too. The uninstall/reinstall worked and fixed the problem. I'm not doing anything unusual on my local network. I have an I-omega network drive, that seems to be linux smb based, and a HP printer (not sure if this uses smb too). Also 3 laptops which can share using Workgroup access. If the problem pops up again, then I'll contact support. The only thing that I can think could of triggered something, is that I removed some bloatware from Intel off my laptop (its a new laptop). There was a utility to support wifi sharing/chaining, but my adapter didn't support this feature. Removing it may have changed the driver status, enough to throw Bullguard.

Posted By : Andreea-Luciana Ostache - 5/1/2014 8:49 AM
You are most likely correct in identifying what happened, since reinstalling (the Firewall driver) corrected the issue.
I am glad things worked out!

As for the logs, it's not as simple as using the logs BullGuard creates. To investigate this kind of issue, usually event logs are required, along with a system summary and the Firewall logs. The information from these combined lead us to finding the problem, so that we can offer a solution.

I do not encourage using the forum for fixing BullGuard issues, because the forum is managed by volunteers which may or may not check it in a timely fashion. The support is available 24/7 and the team is qualified for solving any issues, BullGuard related or not. We do not offer general help, generally, but if it's something we can help with, we will at least point you in the right direction.

Andreea-Luciana Ostache
Senior Support Technician EN

Download the Free Trial version of BullGuard Internet Security 14

You have a BullGuard related problem? Post your question on these forums, contact Support or contact me on Twitter!