The original version of this page can be found at : http://forum.bullguard.com/forum/30/Titanfall-Vista-x64_96755.html
Posted By : Utarg - 3/17/2014 10:46 PM
Hello, i run the latest build of Bullguard internet security on Vista x64 home premium, latest updates sp etc, i cannot play Titanfall, upon loading the game sits at data centre searching and fails to find a server list, all servers report -1 ping, i have contacted EA support and after a lengthy test and discussion, we got it working, by uninstalling Bullguard, the only way i can get it working, when i add permissions for titanfall, it doesnt work, i would rather not uninstall Bullguard everytime i want a session of Titanfall but its the only thing i am able to do at the moment.
 
A second pc is in our house, windows 7 x64 home premium, latest updates sp etc, this had the same Bullguard and we installed origin/titanfall on it, bullguard allows Titanfall to work without issue on that system, both pc are connected to the same network/router, same ports forwarded etc, i am at a loss as to why this is happening on Vista bullguard and not Windows 7, although upgrading vista is an option, its an expensive one that i would rather avoid if possible. Can anyone at Bullguard help us with this issue?

Posted By : Andreea-Luciana Ostache - 3/19/2014 7:12 AM
You definitely do not have to upgrade your Vista to 7 just for this. Please contact our support team and ask to be assisted remotely. Someone will help you get to the bottom of the issues.


Andreea-Luciana Ostache
Senior Support Technician EN
support@bullguard.com
www.bullguard.com

Download the Free Trial version of BullGuard Internet Security 14

You have a BullGuard related problem? Post your question on these forums, contact Support or contact me on Twitter!

-->