We use cookies to ensure that we give you the best experience on our website. By continuing to browse, we are assuming that you have no objection in accepting cookies. You can change your cookie settings at any time.

Supportservice 24/7

Vi är redo att hjälpa dig med alla dina Internet-säkerhetsproblem.

Vare sig du väljer att livechatta eller skicka e-post kan du räkna med att vårt team av experter snabbt svarar på dina frågor.

 

QUESTIONS ABOUT BULLGUARD 8.5

 

 

What's new in BullGuard 8.5?

BullGuard 8.5 is a serious upgrade of our current product. The new version features:

 

*     Remote access for BullGuard Support

*     5 Gigabyte Online Backup Drive

*     Improved Firewall and Spamfilter engines

*     New Backup features include Silent Backup, improved compression and encryption capabilities and Windows Explorer

integration of the Online Drive

 

Read the detailed product info.

 

Do I have to pay for the upgrade?

No. The upgrade is completely free, as always.

 

Find more about how to upgrade to BullGuard 8.5 here: Guide to upgrading BullGuard

 

Is BullGuard 8.5 available in my language?

At the moment BullGuard 8.5 is available in English, Danish, Dutch, French, German and Spanish. More languages will follow soon.

 

Does BullGuard 8.5 work on 64-bit Windows or Vista?

BullGuard 8.5 is designed for Windows Vista, XP and 2000. The differentiation is not made by the operating system, but by the type of processor you have: a 32-bit or a 64-bit.

 

In short: BullGuard 8.5 32-bit works on Windows Vista/XP/2000 32-bit. Similarly, BullGuard 8.5 64-bit is designed for Windows Vista/XP/2000 64-bit.


Note: If you use Windows 98 or Milennium, please note that BullGuard no longer has a downloadable version for these operating systems.


Can I use BullGuard 8.5 with my current account?

Yes. A BullGuard subscription (account) is not linked to the version you have installed. Thus, a BullGuard account can be used with any version of the program, be it the latest, or an earlier one.

 

Note: a BullGuard subscription should include all the plug-ins that the application consists of at any given time. When new versions are launched, all existing user accounts receive the new plug-ins automatically, so that when they upgrade, they can use the new version to its full potential.

 

However if you have bought BullGuard in a box, you may need to have the new plug-ins added to your license. To do this, please contact Support.

 

If you did not find the solution you were looking for, please feel free to contact our Support.

 

Ask Red Live Red Top of page

 

Support 24/7

 


Vårt supportteam är här för dig med expertråd på enkel engelska 24/7 och på andra språk under vissa tider.


Få hjälp nu


Uppgradera / förnya

 


Använder du redan BullGuard?


Vi vill att du ska njuta av våra produkter till fullo!


Uppgradera Förnya